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How Windows XP enables you to work with photos

> AT A GLANCE

As soon as you add a device with photo files, Windows XP should offer you the tools to work with them

START THE WIZARD
Click here to open the wizard, ready
to work with the device that
Windows has spotted the pictures on

YOUR PHOTOS
When you plug in a removable
drive or put in a CD, Windows XP
looks at the type of files on it and
offers you relevant AutoPlay
options

YOUR CAMERAS
Turn on ‘Show in Groups for My
Computer’ and your digital camera
or Web cam will show up here

MAKE YOUR MIND UP
If you always want to open the
Scanner and Camera Wizard
automatically, tick here to skip this
AutoPlay dialog in future

Windows XP
Scanner and
Camera Wizard
Mary Branscombe makes scanning and managing photos simpler in XP. 
From archiving images to tracking down lost wizards, you’ll find it all here

COMPLETE
GUIDE

PCA131.compg  20/2/04  3:01 pm  Page 20



W indows XP is pretty good at
dealing with media. Look
at a photo or an MP3 file in

Explorer and you can find out a lot
about it without having to open it
because you can see the metadata for
the file. For images this includes the
EXIF data from the camera, such as
when you took the photo (rather than
when you copied the file to your PC)
and whether the flash was on or not.
To make it easier to work with your
photos, XP has the Scanner and
Camera Wizard, which helps you
transfer photos, scan images and work
with image files on your PC.

You don’t have to use the
Scanner and Camera Wizard to
access your photos. Most scanners
come with their own scanning
software and most digital cameras
show up as a removable drive in
Explorer so you can just click the
drive letter to open them. Your

pictures will probably be in a sub-
folder rather than in the root of the
drive. You can drag the images into a
folder on your hard drive to copy
them to your PC, but you have to
delete them by hand and you have to
change the file names individually,
too. You may be able to preview
them in the camera by switching the
view to Thumbnail, but it’s slow
unless you have a USB2 connection.

Multi-talented wizard
Yet it’s worth giving the wizard a try
because it does more than just giving
you a simple interface for getting

images on to your PC. For a start, it
works with a variety of devices,
including Web cams as well as
standard digital cameras and

scanners. Many Web cams have
internal memory that you can store
photos in.This is handy for doing
time-lapse photography or taking a
few quick snaps to see which you like
best, which is much more convenient
when you don’t have to transfer the
images one at a time. Start the wizard
with your Web cam and you are
presented with a live preview for
taking your snaps. In addition, you can
see any images you’ve taken with the
Web cam and not deleted or
transferred already.

You can also use it with a CD of
photos that you’ve archived from your

PC (or if you’ve had a traditional
camera film developed on to CD). As
soon as Windows XP spots that you’ve
put in a CD with pictures on it, the
AutoPlay dialog asks you if you want to
start the wizard to transfer them to
your PC.

Once you’ve transferred your
photos, you can publish the ones you
like best straight to your Web site, or
send them to an online service for
professional printing, all without
leaving the wizard.
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STRAIGHT TO PRINTING
Click here if you want to print the
pictures straight away without
copying them to your PC first

ANYTHING WITH
PICTURES
It doesn’t matter if you use a card
reader for your memory card, you
have a CD full of photos, or you
don’t have the specific driver for
your camera so Windows only sees
it as a removable drive. As long as
there are photos on there the
wizard will work

THE WIZARD WORKS WITH A VARIETY OF
DEVICES, INCLUDING WEB CAMS

> IN THIS SECTION

Scanning tips p22
Troubleshooting the wizard p23
Configure Windows p24

Compatible with Windows:

If your Web cam can store pictures you can see those in Explorer as well as the live image

The wizard copies, renames and deletes the images from your camera all in one go

Top printing
advice

> BETTER PRINTS

The Photo Printing Wizard is
similar to the Scanner and
Camera Wizard: it walks you
through picking the images
you want and laying them out
on the page so you don’t waste
paper. It can be a bit tedious to
keep clicking Next if you’re only
printing one picture. Instead,
you can drag the image file on
to the icon of your printer in
Explorer to get a full-page
print.That only uses your
printer’s default settings, so
use the wizard if you want to
check the resolution or select
manual feed rather than the
main print tray. It’s also worth
spending a few seconds
checking that your printer
cartridge is aligned before you
print on photo paper.

Speed up your prints
and get better pictures
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A ll scanners come with their
own scanning software, but as
long as there’s a TWAIN driver

you can use it in any image-editing
software.The scanning interface in the
Windows XP Scanner and Camera
Wizard is simple, and it has the key
features you need to get your photos
into your PC.

You can start it by double-clicking
your scanner in My Computer or from
inside an application if you know you
want to use the image there. If you’re
working from an application and
you’ve got more than one device on
your PC, remember to pick your
scanner from the drop-down Device
menu. This will also show your digital
camera and any other image devices
on the system because you can 
insert a picture from a digital 
camera or Web cam through the
same interface.

As you’re scanning an image
rather than importing a digital photo
or grabbing an image from a Web
cam, it doesn’t matter whether you
choose Web Quality or Print Quality
for Resolution at this stage because
you’ll be able to choose exactly what
you want later in the wizard. Print
Quality gives you larger images that
print out better. In contrast,Web

quality lowers the image resolution
so you get a smaller file that’s good
enough to look at on screen and
won’t take long to upload or email
but doesn’t look as good printed.
Click Custom Insert to set the options
for scanning.

Your scan, your choice
Like the rest of the wizard the dialog is
simple but it has the settings you’ll
need most.You can choose to scan in
colour, greyscale or black and white
(use black and white if it’s a document
you plan to use for optical character
recognition at some point).You can
also choose Custom and Click Custom
settings that enables you to pick the
brightness, contrast and resolution to
scan at as well as setting whether it’s a
colour, greyscale or black and white

image.You can only use the optical
resolution of the scanner because the
wizard can’t do interpolation, unlike
the software that’s designed to drive
the scanner. If you’re going to use an
image on screen – a Web page or a
PowerPoint file – then 75dpi is enough.
For images you plan to print out again
pick something between 150 and
300dpi, depending on much disk space
you’ve got free.

Click Preview: if there’s only one
picture on the scanner the wizard will

automatically select it, although you
can drag the scanning boundaries if
you only want a particular section of
the image.You can put several images
on your scanner at once and choose
the scanning area for each of them by
hand.When you click Scan the wizard
asks for a group name and the file 
type you want: there’s the choice of
BMP, JPG,TIF and PNG. If you want
to scan several pictures one after
another click Back instead of Finish 
on the final screen.

Straightforward scanning tips

Different ways of scanning

Double-click your scanner in My Computer and
you’ll be faced with an AutoPlay dialog with

the choice of scanning using the Scanner and Camera
Wizard or through another application such as
Photoshop.

You can start the wizard from Explorer, from an application or from the scanner

01 If you want to start scanning by pressing a
button on your scanner you can set that up

from the Scanners and Cameras control panel. Pick a
button that’s assigned to a task you don’t use, like
sending a scan by email.

02 You can also start the scanning wizard from
inside any application that works with

documents. In image-editing applications the
command is usually on the File menu but in Word
it’s Insert -> Picture -> From Scanner or Camera.

03

The wizard has simple controls for the most common types of scan

Most apps that work with documents can
use the wizard to grab an image directly

Get the pictures you’ve already got into your PC with the minimum of fuss

>STEP-BY-STEP GUIDE
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Usually,the wizard opens
automatically when you connect
your camera or put a memory

card into your reader. If it doesn’t,you can
try opening it from the My Pictures task
pane or right-clicking the camera in My
Computer and choosing Get Pictures. If
you open the Scanners and Cameras
control panel you’ll also get the tools
from the wizard in the task pane when
you click your camera.Set your Start

menu to show Control Panel as a
cascading menu and you can navigate
straight to your camera.

The most common reason for the
wizard not opening automatically is that
you’ve turned off AutoPlay for removable
devices.You can turn it back on by hand
in the Registry.Find the HKEY_CURRENT
USER_\Software\Microsoft\Windows\
CurrentVersion\Policies\Explorer key and
make sure that the NoDriveTypeAutoRun

value is a REG_DWORD with the value
0x00000091 (145 decimal). More simply,
download a copy of Tweak UI from
www.microsoft.com/windowsxp/
pro/downloads/powertoys.asp. In Tweak
UI click My Computer -> AutoPlay 
-> Types and turn on ‘Enable Autoplay for
removable drives’.

If that doesn’t work,especially if the
wizard worked when you first plugged
your camera in but it doesn’t work any
more, then make sure the Shell
Hardware Detection service is set to run
automatically and log off and on again.
Explorer only tries to register with the
service when you start your PC. If it’s not
working at the time, it won’t try to
register again late and so it never gets a
notification that you’ve attached a new
device,which is what triggers AutoPlay.

It’s also possible that there are more
serious problems with AutoPlay,
especially if you get the AutoPlay dialog
but can’t get the Scanner and Camera
Wizard to run.Check in the Registry for
the [HKEY_LOCAL_MACHINE\
SOFTWARE\Classes\WIA.Autoplay
DropHandler.1\shell\open\DropTarget]
key (if it’s not there create it).The Clsid
value should be a REG_SZ string with
the value {F1ABE2B5-C073-4dba-B6EB-
FD7A5111DD8F}.Again, it’s simpler to use

the AutoPlay Repair Wizard that’s
designed to check and fix problems with
AutoPlay settings.Search on www.
microsoft.com/downloads for AutoPlay:
the file is called AutoFixe.EXE.You can
press the Repair button to apply the
automatic fixes, then click Open Log to
see what it’s changed.AutoFix only
works with cameras and devices that
show up in My Computer as removable
disks with their own drive letter.

If you’ve got your digital camera
plugged into a USB hub and you find it
doesn’t work after you’ve unplugged 
it and then connected it, it’s possible
that the USB hub isn’t responding.
There’s a fix for this in the Microsoft
Download Centre too:search for
Q810400_WXP_SP2_x86_ENU.exe 
to download it.

Fixing problems with the wizard
What to do if you can’t find the Scanner and Camera Wizard

Publishing your photos online

Once your photos are on your PC the wizard
asks if you want to stop, print your photos or

publish them to a Web site.The interface is similar, so
you can pick a selection of your images. Furthermore,
you don’t have to only choose images you’ve just
transferred because the wizard points at My Pictures.

>STEP-BY-STEP GUIDE

Use the Scanner and Camera Wizard to put your photos on to a free Web site

01 Which Web hosting services you see here
depends on what you already have set up on

your PC, like Yahoo Messenger, but you’ll always get
MSN Groups. You don’t have to have an MSN
account already: you can sign up through the wizard
because it just loads the appropriate Web pages.

02 Resize your pictures so they’re smaller files.
You have a limited amount of space on the

site so you’ll fit more pictures in this way, plus they’ll
upload more quickly. If you want to make the images
smaller, use the Image Resizing PowerToy in Explorer
and choose the resized images in the wizard.

03

If the Scanner and Camera Wizard doesn’t start when you connect your camera, use 
Tweak UI to turn AutoPlay back on

If the wizard doesn’t start automatically
click the link on the Task bar in My Pictures
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There’s more you can do to
Window XP to make it easy to
work with photos than just

turning on the common tasks pane in
my Pictures or switching to the
Filmstrip view. For a start, make sure
that your monitor is calibrated and
that you’re using the right profile for
your monitor. Calibration sets up your

monitor so that white is white, black is
black and grey doesn’t have any tinge
of colour in it, and it sets the screen
brightness to the best level.Then you
can profile how the screen displays
colours, so that Windows can adjust
the signals it sends to get an accurate
image of your photos.

Consider calibration 
You can calibrate your monitor by
hand in a program like Photoshop,
adjusting the brightness, contrast and
colour temperature until the on-screen
calibration tools look right.You get a
much better result with a clip-on tools
that measures the colour on-screen
exactly. Start with a colour
temperature of 65,000K (D65 or cool
white) and a gamma of 2.2. Look on
the Web site for your screen to see if

there’s a standard monitor profile you
can download to start with and
choose it in the Display Properties
control panel. Right-click the desktop
and choose Properties -> Settings ->
Advanced -> Colour Management and
pick the profile. Profile files are usually
in C:\WINDOWS\SYSTEM32\SPOOL\
DRIVERS\COLOR. �
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HOW IT
WORKS
The wizard can connect
to most cameras
without a driver

> INSIDE INFORMATION

When you plug a new device
into your PC the hardware
recognition service informs
Explorer about the new device.
If there’s an AutoPlay setting
defined for the type of files on
the device it opens the
AutoPlay dialog with the list of
tasks that are set up for those
file types.When you put in a

CD that doesn’t have an
AutoRun.INF file it’s the same
process, so the Scanner and
Camera Wizard works just as
well for retrieving photos
you’ve archived on to a CD as
for getting them from your
camera in the first place.

The wizard works with
almost any camera because it
can use PTP (Picture Transfer
Protocol) to control the camera
without having to use the
software that comes with the
camera.This is a standard USB
protocol for transferring still
images, and if your digital
camera supports it then you
don’t need to install a driver –
just plug it in and Windows
can work with it.

PTP cameras show up as
removable hard drives in
Explorer, but the wizard can
also work with cameras in USB
mode as long as you have the
drivers. If you can use a digital
camera as a Web cam the
wizard takes the streaming
images from the camera in
USB mode rather than PTP.

T he internal name your camera
creates for a photo is pretty
meaningless and the wizard

renames the files for you using the
description you give it as the group
name. Although you can always sort
the folder by date to get things in
order, it’s worth including a date in the
file name because if you edit the file
later then it gets a new datestamp. Put
the year at the beginning of the
filename: it’s less intrusive, it won’t get
confusing when the wizard adds 002
to the end of the filename for your
second picture and it’ll keep you’re my
Pictures folder roughly sorted by date
even when it’s sorted alphabetically.

Bypass the wizard
Rather than clicking through the
wizard screen by screen, you can
instruct Windows XP to transfer
pictures automatically as soon as you
plug in your camera (this works for any
Plug and Play camera that supports
PTP or has a Windows image
acquisition (WIA) driver).This is ideal
for cameras that don’t show up as

removable drives in Explorer but just
appear in My Computer.

Right-click the camera in My
Computer and choose Properties ->
Events -> Save all pictures to this folder.
If the folder you want isn’t in the list,
click Browse to find it. Choose Delete
pictures from camera after saving

them: not all cameras support it so
you may have to delete them by hand,
but if your camera can manage it this
frees up your memory card quickly.
Remember to rename the pictures in
Explorer: you can select the whole
batch and use File -> Rename to
change all the filenames at once.

Make your photos work better once you get them on to your PC

Your pictures don’t have to be on a camera – you’ll get the wizard for a CD of photos, too

Use the correct colour profile and you’ll see
a more accurate view of your photos

Don’t rotate images in the viewer – you’ll
lose detail

Configuring Windows to
make the most of photos

The wizard can show you information
about the files based on the EXIF data

The wizard saves you time – here’s how to save more
Advice for working with photos
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